Dodge Charger Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. 2013 Dodge Charger Forum
    Hey guys I'm new here. I have an awesome 2013 Charger SE. Anyway, I had my audio system sweet. Buuuuut, I was talked into getting a Clarion EQ. Long story short...it didn't work. And I do the work myself....I let my friend do it. Next thing you know I have no sound from speakers, muffled...
  2. Dodge Charger General Discussion
    So I bought a 07 RT hemi a couple weeks ago. They had a jvc 6.1” radio in that was rough. So I replaced with a pioneer 1500nex. They also had a PAC interface module already in there. Hooked it all up but I get no sound out of the back speakers. (This is the 7 speaker boston acoustic System) any...
  3. 2007 - MOTM
    I just replaced the head unit in my 07 R/T. It’s the navigation model. I used the replacement interface to hook up the new radio. Got it all together but no sound out for the rear speakers. (It has 4 6x9s in the back). Am I missing something? I also read something about mixing up the connections...
  4. 2014 Dodge Charger Forum
    hey guys. I’ve got a 2014 charger rt with the beats system. Sound was cutting in and out one day. at first, there was no sound, then it would just magically start working after driving a few miles. Well now it won’t produce sound whatsoever. Even after driving for 100+ miles, it won’t produce...
  5. 2012 Dodge Charger Forum
    I have installed many basic systems before without a hitch, BUT, recently I attempted to install a sub, amplifier and line control without success. No sound from rear at all. LC2i line controller turns on, amp turns on. I bought everything from Crutchfield and their techs haven't been able to...
1-5 of 5 Results
Top