Dodge Charger Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey guys i have some issues going on is there a easy way to tell if its my ecm on the firewall or my front control module on the fuse box i get the bas and esp light and a bunch of other lights as well but i also cant connect my obd2 reader when its wigging out to scan for codes it also will sometimes mess with my door locks while i am in the car it starts and runs but sometimes it wont it will just start and die before you can even get it in drive
 

Attachments

·
Registered
Joined
·
2,814 Posts
Only way to test the FCM is with the diagnostic system used by the dealership. Apparently the dealership you went to does not have a qualified technician ... otherwise, they would have been able to isolate the problem. It could be the FCM, a wiring harness issue, ground problem or a CAN Bus termination problem. Is there another FCA dealership in your area?
.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
The dealership i took it to said that they couldn't get it to replicate but i literally got it home and boom it did it again i am currently looking into another dealership at the moment i did however pull some fuses that run my pcm in the front fuse box and switched them with a step up so went from a 5amp to a 10amp and i think from the 2 15 amps to a 20 amp and did a gauge cluster reset and very oddly the lights cleared them selves not sure if that is a good thing or if it will short out what is the problem
 
1 - 5 of 5 Posts
Top