Dodge Charger Forum banner
101 - 118 of 118 Posts

·
Registered
Joined
·
76 Posts
Only because I'll already have the timing chain off and because it came in the kit of parts I bought, I also bought an oil pickup tube too. Though after research, the oil pump replacement requires dropping the oil pan which is its own pain in the butt, so depending on how I feel I may decide to do that on another date.
Oh dang, you are doing this all yourself? Better than me, i am too scared to do that myself. I will mostly everything else, but timing chain and all that mess scares me.

Tech49
 

·
Registered
Joined
·
42 Posts
Yeah to be honest I'm a little scared but I have the tools and I've watched a lot of videos and I have a friend that could help me so I think I'll be OK if I take my time and make sure I do it right. I don't have the money for a mechanic so I'm gonna have to do it.
 

·
Registered
Joined
·
76 Posts
Yeah to be honest I'm a little scared but I have the tools and I've watched a lot of videos and I have a friend that could help me so I think I'll be OK if I take my time and make sure I do it right. I don't have the money for a mechanic so I'm gonna have to do it.
Well I feel you on that, I have done tons of research too. If you need help, I have the Chilton program for free (Army gives it to us) and I can paste the instructions in here.
 

·
Registered
Joined
·
1,055 Posts
Yes it is 2006 and has 89K Miles and she is KICKING ASS !!!!!!!!!!!!!!!!!!
 

·
Registered
Joined
·
42 Posts
Mine is up to 187K now, I replaced my Timing Chain and Water pump a few weeks ago and everything is working! I keep getting an EGR code every so often, I keep clearing it and will stay off for a few days then pop back on at random. I've replaced it several times, seems to be ok for a few months then it will happen again.
 

·
Registered
Joined
·
76 Posts
Mine is up to 187K now, I replaced my Timing Chain and Water pump a few weeks ago and everything is working! I keep getting an EGR code every so often, I keep clearing it and will stay off for a few days then pop back on at random. I've replaced it several times, seems to be ok for a few months then it will happen again.
Hey brother, have you tried replacing your EGR tube seal or you EGR seal? I know I had an EGR leak and it was because when I took off the plenum, apparently I ripped the EGR tube seal and it was causing the engine to run rough and throw a code. Just a thought. If you deiced to replace the tube seal, I suggest buying them on Ebay or somewhere else online. I personally keep at least one spare in my toolbox just in case. Good luck bro. Just broke 150,000 miles on my baby too.
Tech49
 

·
Registered
Joined
·
42 Posts
Yeah I just put a new one on when I did the timing chain/water pump. I also had to replace my PCM because it had a shorted Injector driver. I wondered if the replacement PCM had an issue with the EGR detection. It's not running any different at the moment, maybe I should make sure my tube seal is sealed well. I might need to have the tubes cleaned real well, I dunno it's just annoying. I've replaced the EGR valve like 6 times in 2 years, a couple of them were faulty out of the package
 

·
Registered
Joined
·
1,189 Posts
Discussion Starter · #108 ·
Knock on wood, Still running Strong. at 62,XXX miles now.

Ported TB, Hypertech Tune, Big Bully intake and exhaust.

Car is paid off pretty much. I think I have 2 payments left.

Going to keep driving it for a little while longer. Then Swap the 2.7L for a 5.7L or 6.4L. Depending on what deals I find. I even came across a Good running 6.0L i thought about, but my Dad is going to put it in an Old School GTO.
 

·
Registered
Joined
·
1,055 Posts
I am now a 2006 SRT-8 with 91000 miles on her, Ready to go another 200000 !!!!!!!!!!!!!!
 

·
Registered
Joined
·
1,189 Posts
Discussion Starter · #110 ·

·
Registered
Joined
·
42 Posts
Yeah I just put a new one on when I did the timing chain/water pump. I also had to replace my PCM because it had a shorted Injector driver. I wondered if the replacement PCM had an issue with the EGR detection. It's not running any different at the moment, maybe I should make sure my tube seal is sealed well. I might need to have the tubes cleaned real well, I dunno it's just annoying. I've replaced the EGR valve like 6 times in 2 years, a couple of them were faulty out of the package

Well after I replaced the EGR valve that time, I was code free up until about 2 weeks ago. My EGR valve failed...again. The upside is I can replace it in about 60 minutes now haha!

BTW now I'm up to 208,000 miles and dreading the next big expense. Probably the transmission.
 

·
Registered
Joined
·
15 Posts
Just wondering how long these 2.7L's are going to hold up. What kind of miles can I get out of mine and what can I expect to go wrong? Anything they're known for going wrong? Leaks, trans, etc....
When I got my charger it had 240,xxx with the 2.7 and it had spun a rod bearing everything was all original in the motor even the water pump which is what caused the water In oil and spun bearing.... if they woulda checked the oil regularly they coulda seen the water in the oil and replaced the water pump and that motor would have still been running. Got lucky and picked up the car for $800 put a $300 replacement motor in it from a junk yard which looked like it had around 50,000 miles or less on it, perfectly clean inside the whole thing..... Factory motor had 1/4 inch of sludge on everything from cheap oil and not being changed regularly. If you do the proper maintenance on an engine with quality parts and oil, it will last forever.
 

·
Registered
Joined
·
1 Posts
I have 126,000 miles on my 2.7L and it’s still going strong. Only problem I’ve had is I have to replace the strut the second time. Have never had any other problems. This is my first post by the way. I’m new. I just bought my Charger maybe 3 weeks ago. The guy I bought it from kept extremely good care of the car. He kept it inside whenever he was not driving it, and knew how to work on a car.
 

·
Registered
Joined
·
2 Posts
Just wondering how long these 2.7L's are going to hold up. What kind of miles can I get out of mine and what can I expect to go wrong? Anything they're known for going wrong? Leaks, trans, etc....
Mine just blew with 110,000 on the dash. Regular routine maintenance with full synthetic oil changes, mopar filters the whole 9. Just paid it off and scratching my head on what to do
 

·
Registered
Joined
·
2 Posts
When I got my charger it had 240,xxx with the 2.7 and it had spun a rod bearing everything was all original in the motor even the water pump which is what caused the water In oil and spun bearing.... if they woulda checked the oil regularly they coulda seen the water in the oil and replaced the water pump and that motor would have still been running. Got lucky and picked up the car for $800 put a $300 replacement motor in it from a junk yard which looked like it had around 50,000 miles or less on it, perfectly clean inside the whole thing..... Factory motor had 1/4 inch of sludge on everything from cheap oil and not being changed regularly. If you do the proper maintenance on an engine with quality parts and oil, it will last forever.
Man I’d love to find a used $300 motor
 

·
Registered
Joined
·
1 Posts
Ive got a 2007 R/t with 29,500 on it and my transmission feels sketchy at time idk if its normal or what it just shifts hard or wont shift up when ure coasting in parking lots its not that bad though when im hard on it it seems fine its almost like its meant to be beat on but when you baby it the trany gets upset
Im not sure, Maybe try researching about a TCM(Transmission Control Module) flash or update. May help, may not.
 
101 - 118 of 118 Posts
Top