Dodge Charger Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 · (Edited)
I have an 09 Charger 5.7 hemi NAG1 transmission. It was an interceptor column shift. I converted to floor shift (auto stick) upon completion, I pulled out of my garages and when it got 20 mph it felt like it was in 2 gear and was sluggish to move. It ha no reverse at all. I shut off and started back up and it had reverse and was back in first when in drive. Same thing occurred when i hit about 20 mph. I used a Snapon scanner and confirmed the shifter is reading properly as well, checked the wiring. A code of P0731 came up saying incorrect ratio. I seen a common problem was the conductor plate. I changed that and the filter. Still doing it.

One of the front wheel bearings were growling before the shifter swap. Maybe the wheel sensor ring on the bearings? I’ve only had the car for a week.
I’m lost here 🤷🏻‍♂️
 

·
Registered
Joined
·
1,697 Posts
How did you measure the Trans fluid level?
 

·
Registered
Joined
·
1,697 Posts
You need to check the fluid level. The NAG1 is extremely sensitive to the amount of fluid. To little or to much can present the problems you are having.

A Miller Tool is normally used but some folks use zip ties and other stuff. There is also a guide online as to the correct amount of fluid per temperature. Check this link out:

.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #5 ·
You need to check the fluid level. The NAG1 is extremely sensitive to the amount of fluid. To little or to much can present the problems you are having.

A Miller Tool is normally used but some folks use zip ties and other stuff. There is also a guide online as to the correct amount of fluid per temperature. Check this link out:

.

Thanks I’ll look into that
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #6 ·
You need to check the fluid level. The NAG1 is extremely sensitive to the amount of fluid. To little or to much can present the problems you are having.

A Miller Tool is normally used but some folks use zip ties and other stuff. There is also a guide online as to the correct amount of fluid per temperature. Check this link out:

.

also I’ve only had this car for a week. The guy I bought it from had it in storage and they had change the rear end to an “ upgraded rear end”. I’m saying something about the gear ratio being different will cause the p0731 code
 

·
Registered
Joined
·
1,697 Posts
On the chargers with the NAG1, you have a TCM that needs to be programmed with a change in the gear ratio. Any time the rear gears are changed and you leave the TCM alone it will go into limp mode until you change it.

Do you know what rear end he put in? Did you drive it before you got the charger? It would not go into limp mode after a week of driving. Once the rear end is changed to a new ratio, the TCM has to be programmed or you are not going anywhere except with the first or second gear. (My understanding. I went to a 3.92 rear and it would not shift out of 2nd until I got the TCM programmed right) Maybe someone else can chime in.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #8 ·
On the chargers with the NAG1, you have a TCM that needs to be programmed with a change in the gear ratio. Any time the rear gears are changed and you leave the TCM alone it will go into limp mode until you change it.

Do you know what rear end he put in? Did you drive it before you got the charger? It would not go into limp mode after a week of driving. Once the rear end is changed to a new ratio, the TCM has to be programmed or you are not going anywhere except with the first or second gear. (My understanding. I went to a 3.92 rear and it would not shift out of 2nd until I got the TCM programmed right) Maybe someone else can chime in.
I put about 100 miles on the car after I bought it. Pulled into my garage, put it on my Lift to change that shifter cable to the longer one for the floor shift and whenever I finish the install it started doing this
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #9 ·
I put about 100 miles on the car after I bought it. Pulled into my garage, put it on my Lift to change that shifter cable to the longer one for the floor shift and whenever I finish the install it started doing this
I think I got it man. I just went through the tuner and adjusted the axle ratio went through each of them until it started shifting right. Thank you for Your responses
 

·
Registered
Joined
·
17 Posts
I think I got it man. I just went through the tuner and adjusted the axle ratio went through each of them until it started shifting right. Thank you for Your responses
I did not know you could change it to floor shift. I have an 09 Charger PP. I'd love to get rid of the janky column shifter. How hard is it to change over? What parts are needed? What is the procedure?
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #11 ·
I did not know you could change it to floor shift. I have an 09 Charger PP. I'd love to get rid of the janky column shifter. How hard is it to change over? What parts are needed? What is the procedure?
You have to change the cable, center console, and wire the auto stick controller. there are a few videos on the wiring and as for everything else, it bolts right in. You're better off getting a donor car or going to a junkyard and grabbing everything you need.
 
1 - 11 of 11 Posts
Top