Dodge Charger Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
398 Posts
Discussion Starter · #1 ·
2011 Pursuit,
2015+ Cluster
2013 RB5 Radio

No issues prior to fuel pump replacement.

Replaced failed fuel pump with a Delphi unit last month. Got this code with the gauge cluster acting weird. Replaced pump under warranty again and made sure electrical connections were snug in place.

Code keeps popping up on second fuel pump.


Do I need to get a factory pump (#300 bucks man!) or can I get a senfer unit to swap out?
 

·
Registered
Joined
·
1,321 Posts
I know the newer OE pumps come with a harness and instructions to change the wiring positions, I didn't see it and she would not start. I ponder if you have something similar?
 

·
Registered
Joined
·
30 Posts
2011 Pursuit,
2015+ Cluster
2013 RB5 Radio

No issues prior to fuel pump replacement.

Replaced failed fuel pump with a Delphi unit last month. Got this code with the gauge cluster acting weird. Replaced pump under warranty again and made sure electrical connections were snug in place.

Code keeps popping up on second fuel pump.


Do I need to get a factory pump (#300 bucks man!) or can I get a senfer unit to swap out?
You've replaced both fuel pumps? Primary and auxiliary or just the Primary under the drivers side back seat. I changed both of mine to come to the conclusion it's most likely my cluster.
 

·
Registered
Joined
·
398 Posts
Discussion Starter · #4 ·
I know the newer OE pumps come with a harness and instructions to change the wiring positions, I didn't see it and she would not start. I ponder if you have something similar?
Neagtive. Same plug. Code goes away every so often.
 

·
Registered
Joined
·
398 Posts
Discussion Starter · #5 ·
You've replaced both fuel pumps? Primary and auxiliary or just the Primary under the drivers side back seat. I changed both of mine to come to the conclusion it's most likely my cluster.
Just the actual only*** fuel pump driver side. Passenger side is just a level sender, and fuel pressure regualtor. (also cool design lets the wasted fuel from FPR help siphon fuel back to left side to feed pump)
 

·
Registered
Joined
·
30 Posts
I can't find it on here, but I've see p0461 and p0462 are the primary and p0463 was the secondary..... p0463 was my intermittent error come and go constantly and not keeping a proper gas reading. Changed the pump behind the drivers seat.... still same error. So I changed the secondary (rockauto has it listed as auxiliary).... since I've changed it, the p0463 has come back only one time. But has not come back since. And it's been maybe 2 - 3 months. But the fact it did come back makes me think it might be a cluster error for me.
 

·
Registered
Joined
·
398 Posts
Discussion Starter · #7 ·
I can't find it on here, but I've see p0461 and p0462 are the primary and p0463 was the secondary..... p0463 was my intermittent error come and go constantly and not keeping a proper gas reading. Changed the pump behind the drivers seat.... still same error. So I changed the secondary (rockauto has it listed as auxiliary).... since I've changed it, the p0463 has come back only one time. But has not come back since. And it's been maybe 2 - 3 months. But the fact it did come back makes me think it might be a cluster error for me.
I was thinking perhaps having one new and one old sender may cause the issue. May end up replacing it. My car does have a 2015+ cluster swap, but had no issues until I swapped the pump out.
 
  • Like
Reactions: Dave chart
1 - 7 of 7 Posts
Top