Dodge Charger Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
A little over a week ago my abs light and traction control light came on. I hooked up my code reader and it gave me ABS code C0031-4a say the incorrect left front wheel speed sensor was installed. I got the sensor from autozone it was a duralast part.

Do you all think that I need to order the wheel speed sensor directly from mopar and get the OEM part instead of the aftermarket duralast part to get the annoying lights to go off?
 

·
Registered
Joined
·
1 Posts
Buy them from the dealer, 2015 SXT and both my fronts have failed in the same week, $31.10 from dealer part number 68199987AC
 

·
Registered
Joined
·
19 Posts
Only buy oem mopar part.
I can confirm that aftermarket part didn't work but Mopar part did.
The aftermarket part in my case ALS2892 cleared the original code but set off a new one saying incorrect component installed. Even though it's listed as 68199987AA, 68199987AC replacement...
 

·
Registered
Joined
·
1,792 Posts
I just went through this on my '15 Rallye last week. The left front wheel speed sensor went bad on my car also. Be careful purchasing the Mopar part. Apparently there are 2 different part numbers for the 2015 Chargers. I originally ordered the 68199988AD part from my local dealer, since moparpartsonline said that was the correct part number for a 2015 Charger. A few minutes after ordering the sensor, the parts manager called me back saying he had looked up my VIN (I purchased the car there) and his listing showed a different part number (68199987AC), so I ordered the part number he suggested. Of course, the correct part number for my car was double the price of the other sensor. What I don't know is if the other (cheaper) sensor would have worked or not.
 
1 - 4 of 4 Posts
Top