Dodge Charger Forum banner
1121 - 1127 of 1127 Posts

·
Registered
2014 Dodge Charger R/T RWD
Joined
·
2 Posts
I’ve read through a good chunk of these replies and have yet to find a solution to my problem. So I did the cluster swap the other day in my 14 Charger RT. It’s a 2020 cluster, the cluster works, shows all my info (as far as I can tell, I have a tazer on the way) but my gas hand does not update. Is there something wrong with my cluster or is it the wiring harness. It worked before I did the swap, or is that something the tazer will fix? Any suggestions?
 

·
Registered
Joined
·
421 Posts
I’ve read through a good chunk of these replies and have yet to find a solution to my problem. So I did the cluster swap the other day in my 14 Charger RT. It’s a 2020 cluster, the cluster works, shows all my info (as far as I can tell, I have a tazer on the way) but my gas hand does not update. Is there something wrong with my cluster or is it the wiring harness. It worked before I did the swap, or is that something the tazer will fix? Any suggestions?
When you first turn it on, does the gauge (display) move up and down?


Possible there is a can bus difference in 2020. May need to get older cluster.
 

·
Registered
Joined
·
2 Posts
I’ve read through a good chunk of these replies and have yet to find a solution to my problem. So I did the cluster swap the other day in my 14 Charger RT. It’s a 2020 cluster, the cluster works, shows all my info (as far as I can tell, I have a tazer on the way) but my gas hand does not update. Is there something wrong with my cluster or is it the wiring harness. It worked before I did the swap, or is that something the tazer will fix? Any suggestions?
I have the same issue with the gas gauge. It always showing full. The meter does scroll up and down when first starting up the car while it is running its parameters check. Just gets stuck on full after that. For now I’m using the distance gauge to tell me how much gas is left. I also have the lighting bolt throttle light on. Car runs perfect and everything else works fine besides that. I did use the taser for the cluster swap. I have a 13 srt8 superbee and the cluster is from a 19 scatpack.
 

·
Registered
2014 Dodge Charger R/T RWD
Joined
·
2 Posts
I have much the same issue although no lightning bolt. When I start the car it does cycle the gauges as it should, but it pops straight back to full, regardless of the actual amount of gas. I have narrowed it down to being the cluster. I swapped my cluster back last night to my ‘14 just for a moment to make sure it wasn’t something more than the 2020 cluster and the 14 read accurate. Apparently it’s a known issue with the 19+ clusters that the fuel gauge doesn’t update like it’s supposed to.
 

·
Registered
Joined
·
2 Posts
I have much the same issue although no lightning bolt. When I start the car it does cycle the gauges as it should, but it pops straight back to full, regardless of the actual amount of gas. I have narrowed it down to being the cluster. I swapped my cluster back last night to my ‘14 just for a moment to make sure it wasn’t something more than the 2020 cluster and the 14 read accurate. Apparently it’s a known issue with the 19+ clusters that the fuel gauge doesn’t update like it’s supposed to.
That was actually helpful to know about the 19+ cluster not working well. I ended up taking the 19 cluster out then swapped in a 2017 that I got this week. The gas gauge works and the throttle light is gone. Everything working great now. I appreciate that knowledge. Thank you
 
1121 - 1127 of 1127 Posts
Top