Dodge Charger Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
So ever since buying this car last year i have had nothing but problems. But my current problem are as followed.

Since at 20k miles they had to replace the engine due to shavings in the oil. Since then it sounds like my engine has a rattle going on and just does not sound right to me. Did not sound like this before getting the engine replaced. When i ask Dodge about it they said he had someone from FCA look at the car and said that rattle and the way the car sounds its normal. He said only way is to get a car of the same model to see how that one sounds to compare.

Video -

I am having a problem with the AC. Last year i brought it in and they could not duplicate the problem so nothing was done. Now its been over a year and summer is back and AC problems are still there. Took it to dodge and i always have a code in my car p1009 after looking into this it has to do with the Humidity Sensor in the car. Now dodge has told me this code is normal and will always be in the body of the computer. If you have a 2015 Charger and use AlfaOBD can someone else confirm this code is there? But the problem i am having is when i have the AC on high 7 it will be working just fine and then BOOM sounds like a door shutting and the AC itself blows out very low. Now today after talking to Dodge Service they wanted me to see if it had to do with the Re circulation within the car. He said that if it happens with that is off then its normal. So i checked this theory out. I mostly have the car on LO Auto so that door sound happens all the time. But today i have it on High 7 and press the Re circulation and boom AC worked. When i shut the AC Re circulation off and it barely blows out air. Anyone else seeing this. Dodge is saying its normal. Had a 2014 Dart never saw t his problem before with that car.

Video -
 

·
Registered
Joined
·
1 Posts
I have a '15 SE and that engine definitely doesn't sound right. Maybe have a different dealership look at it? How long have you had the new engine? Is it past the break in period? Haven't had a problem with the ac yet.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #3
I have a '15 SE and that engine definitely doesn't sound right. Maybe have a different dealership look at it? How long have you had the new engine? Is it past the break in period? Haven't had a problem with the ac yet.
New one got put in around 20k and i just hit 34k. That is what i am planing on.
 
1 - 3 of 3 Posts
Top