Dodge Charger Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2012 SRT8 that I am having issues with the A\C. When I bought the car a year ago and the recirculate was not working. I replaced the humidity sensor in April of this year and the A\C has worked perfectly till about a month ago. I was driving to work that morning and I noticed that the recirculate was grayed out on the screen and would not respond to the button at all. Went back out to the car about 4 hours later and it would only blow hot air but the recirculate was working again. I left it and about 3 hours later I came back out and the A\C was working fine again. It worked for the rest of the day making multiple stops and it continued to work. The next morning it was the same thing except this time it never started working again. I parked it that Friday and it sat until Wednesday when I was going to take it to the shop. When I got into the car to drive it there it was working again. Needless to say the shop did not see a issue with working A\C. I have been driving it off and on for about two weeks now and it was fine till the other day. It was pretty much the same issue but has not started working again. I was thing maybe the humidity sensor again or a fuse\relay getting hot. Anyone have any ideas?
 

·
Registered
Joined
·
288 Posts
I would like to know if anyone has the answer to this. I had a 2011 R/T that had this problem but ended up trading it in.
 

·
Registered
Joined
·
2,368 Posts
It wouldn't be a fuse, but could be the humidity sensor again. When it's not working, take it to the dealer and have them trouble shoot at that time. To troubleshoot while it's working is pointless.
 
1 - 4 of 4 Posts
Top