Dodge Charger Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
2013 5.7 Road and Track on Cold Start will race up/down till warm or shifted into drive. I assume its a sensor... Probably intake or maybe cleaning? The air filter is new ... it doesn’t throw a code. Help appreciated
 

·
Registered
Joined
·
1,357 Posts
Check your vacuum hoses and lines.
 
  • Like
Reactions: Rodders

·
Registered
Joined
·
2,925 Posts
Another potential vacuum leak is your intake manifold. Check the bolts for 9 ft. lbs of torque.
Tighten them in a crisscross pattern.

upload_2019-8-19_20-51-22.png
 
  • Like
Reactions: Rodders

·
Registered
Joined
·
64 Posts
Discussion Starter · #4 ·
Have resolved the RPM cycling up/down on cold start by cleaning intake manifold and Running some Seafoam to clean injectors. I was not aware of the nasty intake... (previous owner). It’s been improving throttle response all weekend. Can feel more torque.
 

·
Registered
Joined
·
2,925 Posts
If you want to keep the intake manifold clean, you can install a oil-air separator (aka Catch Can) to trap the oil mist that gets circulated from the crankcase, through the PCV valve, to the intake manifold.
.
 
  • Like
Reactions: Rodders

·
Registered
Joined
·
64 Posts
Discussion Starter · #6 ·
I have one... looking to install it, which is proving to be challenge.
 

·
Registered
Joined
·
115 Posts
I’ve got the “sort-a” same problem. When cold upon starting this thing it idles pretty high till it gets warm. Although it doesn’t run up or down. Just higher than normal. It’s been that way since day one. I’ve got a catch can but have never cleaned the manifold. Sounds like I’ve got a weekend project! Oh and my throttle response is crap.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #8 ·
Rough idle could be dirty injectors for sure. My plugs were recently replaced at 60k and they too were due. Plug wires and PCV might be targeted for you. Can helps long term. IMHO. Good luck.
 
1 - 8 of 8 Posts
Top