Dodge Charger Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
E1EA892B-BE3D-4E4C-8E36-300F62AF9BF0.jpeg


Hello everyone,

I have a Dodge Charger Road & Track edition 2014 Model. I’m having two issues with the car

1) Rpm goes up & down on all conditions. Like even if i press the accelerator on park the rpm is still very very slighty moving. Not too major the car runs fine no vibrations or anything but you can definately notice the slight rpm up and down when you look at the guage. I have cleaned the throttle body still have the same issue. My mech told me its a vacum leak somewhere. How do check for such leaks?

2) If i accelerate the car heavily the check engine light will start blinking but will go off itself if i press the brake & accelerate normally. The odd thing is that the computer is not showing any codes. Not even in the history, no present codes. Nothing its all clear. No misfire shown. No stored codes

All help will be appreciated !
 

·
Registered
Joined
·
948 Posts
For #2, you may need a chrysler tech with a scan tool monitor live readings during acceleration.

For #1, it can be really tough to find a small vacuum leak. I think you spray water at suspect places where you might have a vacuum leak. The water should temporarily seal the leak (steady idle)and then evaporate making the erratic idle return
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Thank you for your response. Even if the check engine light blinks theres no power loss the car still runs the same. Will have to check with the dealer for this. What do you suggest?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #4 ·
Moreover whenever i start my car the rpm is never low. Its always like when its on cold start even if its warm & i close it for a minute and start it again the rpm will be up and come down slowly
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
Can anyone listen to this noise


There are two noises one is i assume from belt which is normal but the other coming from the back tick tick tick sort of. Can anyone tell me what this is
 

·
Registered
Joined
·
948 Posts
I responded to you Aleem. For anyone else that might read the thread, it sounds like you have rod knock.
A clearer example of rod knock on a 5.7L is here:
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #7 ·
A rod knock is usually much louder. This isnt too loud & rod knocks tend to get louder when pressing gas. Mine isnt as loud as in the video & gets 0.5% loud when pressing the gas
 

·
Registered
Joined
·
948 Posts
The test for rod knock is does the ticking noise increase and decrease with engine Rpms. If it does you probably have rod knock. Now your noise does not sound as loud as the other video I posted. Explanation could be the wear in the other engine is more severe than yours. Rod knock is not a good to all bad switch. It starts, then it gets worse the more the components wear out.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #9 ·
The test for rod knock is does the ticking noise increase and decrease with engine Rpms. If it does you probably have rod knock. Now your noise does not sound as loud as the other video I posted. Explanation could be the wear in the other engine is more severe than yours. Rod knock is not a good to all bad switch. It starts, then it gets worse the more the components wear out.

The noise doesnt increases like a heavy rod knock. Just increases 0.5% which will obviously increase because of me pressing the pedal and engine using more power. Otherwise nothing too obvious.
 
1 - 11 of 11 Posts
Top