Dodge Charger Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Engine was running rough this morning felt like it was starving for air as I accelerated to 35 miles an hour in my neighborhood. Then It started smoking out the exhaust like a freight train. Help any ideas it is a brand new engine.
Mods
Afe momentum gt2. Cai
True dual exhaust.

Could either of these caused an issue
 

·
Registered
Joined
·
137 Posts
Engine was running rough this morning felt like it was starving for air as I accelerated to 35 miles an hour in my neighborhood. Then It started smoking out the exhaust like a freight train. Help any ideas it is a brand new engine.
Mods
Afe momentum gt2. Cai
True dual exhaust.

Could either of these caused an issue
I’m no expert but can’t see how either of those mods will cause an issue. If new and under warranty, take it to your nearest dealership. Curious to know what ends up being the issue.
 

·
Registered
Joined
·
787 Posts
Black smoke= gasoline. Bought a 5.0 Foxbody 'Stang once for a ton under market value bc it was spewing black smoke. A MAP and O2 sensor later, good as new.

And what they said, above. Brand new engine should come with some manner of warranty, I'd make them fix it.
 

·
Registered
Joined
·
19 Posts
Oh they are. Dealership is having the engine manufacturer pay for the replacement because they said it was a manufacturer defect that caused the issue.
Aww yeah. New engine. Just remember not to push it too hard. There's a break-in procedure they SHOULD go over with you. If not, come back here :)
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #8 ·
Aww yeah. New engine. Just remember not to push it too hard. There's a break-in procedure they SHOULD go over with you. If not, come back here :)
Yeah I know I went over the break-in procedure on the last new engine and I was about 200 miles shy of finishing the break-in. In the ***** about the situation was I was just leaving for work in my neighborhood and I was only about two blocks from the house and I wasn't even doing 30 maybe 35 miles an hour after I had use the remote start to warm the car in the engine up for 15 minutes before I left my house
 
1 - 8 of 8 Posts
Top