Need Help with Backup Camera

Discussion in 'Dodge Charger Interior Mods & Audio / Video' started by Gematriaa, Jan 6, 2018.

  1. Gematriaa

    Gematriaa New Member

    Joined:
    Nov 21, 2017
    Messages:
    4
    Media:
    5
    Albums:
    1
    Likes Received:
    0
    Gender:
    Male
    Location:
    Iowa
    Vehicle:
    Challenger
    Vehicle Year:
    7th Gen - 2015
    Trim?:
    SRT8
    I bought the 3rd brake light for my wife's Charger, installed it, and had it activated at the dealership. Problem. No video on the radio. He wasn't sure what the problem was without investigation more. So I'm trying to figure out what is wrong. Not sure if its the camera itself or the wiring to the radio unit.

    The activation did work, when put in reverse it shows the screen that says 'Check entire surroundings'.

    I unplugged the camera at the trunk end and re-plugged it in. Still nothing. Looking at the wiring harness I noticed there are 6 wires going in from the camera side and 5 going in from the car side. Don't know if that matters or not.

    The tech suggested that maybe it isn't hooked up behind the radio unit. Looking for any help or suggestions.

    Also if an Charger owners in the area would let me plug my camera into their car to see if it works that would be great too.


     
  2. Mike Gretzinger

    Mike Gretzinger New Member Public Safety

    Joined:
    Oct 15, 2017
    Messages:
    49
    Likes Received:
    12
    Gender:
    Male
    Location:
    Mascoutah, IL
    Vehicle:
    2018 Charger
    Vehicle Year:
    7th Gen - 2017
    Trim?:
    Daytona
    Color?:
    Bright White
  3. Gematriaa

    Gematriaa New Member

    Joined:
    Nov 21, 2017
    Messages:
    4
    Media:
    5
    Albums:
    1
    Likes Received:
    0
    Gender:
    Male
    Location:
    Iowa
    Vehicle:
    Challenger
    Vehicle Year:
    7th Gen - 2015
    Trim?:
    SRT8
    It's a 2012 Charger.
     
  4. krichardson

    krichardson Active Member MOTM Winner! Public Safety

    Joined:
    Oct 4, 2012
    Messages:
    1,245
    Likes Received:
    96
    Location:
    philadelphia, pa
    Vehicle:
    2011 Charger
    Trim?:
    SE
    Color?:
    Dark Titanium
    Not sure what the tech meant but if the camera was not plugged in to the back of the radio unit then that message on the screen probably would not have appeared.
     
  5. Gematriaa

    Gematriaa New Member

    Joined:
    Nov 21, 2017
    Messages:
    4
    Media:
    5
    Albums:
    1
    Likes Received:
    0
    Gender:
    Male
    Location:
    Iowa
    Vehicle:
    Challenger
    Vehicle Year:
    7th Gen - 2015
    Trim?:
    SRT8
    He said maybe the video cable isn't plugged in. Tearing apart the dash is my last resort at this point.
     
  6. Mike Gretzinger

    Mike Gretzinger New Member Public Safety

    Joined:
    Oct 15, 2017
    Messages:
    49
    Likes Received:
    12
    Gender:
    Male
    Location:
    Mascoutah, IL
    Vehicle:
    2018 Charger
    Vehicle Year:
    7th Gen - 2017
    Trim?:
    Daytona
    Color?:
    Bright White

Share This Page