Need help

Discussion in '2011 Dodge Charger Forum' started by Dodgeredline, Dec 21, 2017.

  1. Dodgeredline

    Dodgeredline New Member

    Joined:
    Dec 17, 2017
    Messages:
    10
    Likes Received:
    0
    Gender:
    Male
    Location:
    Tulsa Oklahoma
    Vehicle:
    charger
    Vehicle Year:
    7th Gen - 2011
    Trim?:
    Mopar11
    Well it sad to say the car has problems. Ive search around theres lots of threads on this. My car these morning started fine wen I hit reverse everything shut down an the car started stalling. Then i put it on park an know it wont even start up.
     
  2. SolApathy

    SolApathy ... Moderator Site Supporter Level 5

    Joined:
    Oct 10, 2015
    Messages:
    680
    Media:
    32
    Albums:
    1
    Likes Received:
    197
    Gender:
    Male
    Location:
    USA
    Vehicle:
    Charger SRT 392
    Vehicle Year:
    7th Gen - 2015
    Trim?:
    SRT8
    Color?:
    B5 Blue
    Welcome to the forums, sorry to hear you are having some issues with your car. Is it turning over? Was it slow to start the first time? Have you been experiencing any other issues prior to this?
     
  3. Dodgeredline

    Dodgeredline New Member

    Joined:
    Dec 17, 2017
    Messages:
    10
    Likes Received:
    0
    Gender:
    Male
    Location:
    Tulsa Oklahoma
    Vehicle:
    charger
    Vehicle Year:
    7th Gen - 2011
    Trim?:
    Mopar11
    I just bought it a month ago. An yea it try’s to start but wont go. It was alittle hesitant to start too
     
  4. Dodgeredline

    Dodgeredline New Member

    Joined:
    Dec 17, 2017
    Messages:
    10
    Likes Received:
    0
    Gender:
    Male
    Location:
    Tulsa Oklahoma
    Vehicle:
    charger
    Vehicle Year:
    7th Gen - 2011
    Trim?:
    Mopar11
    I read it could be the recall on the alternator.
     
  5. Dodgeredline

    Dodgeredline New Member

    Joined:
    Dec 17, 2017
    Messages:
    10
    Likes Received:
    0
    Gender:
    Male
    Location:
    Tulsa Oklahoma
    Vehicle:
    charger
    Vehicle Year:
    7th Gen - 2011
    Trim?:
    Mopar11
    The fuse box is clicking an the dashbord is flashing
     
  6. SolApathy

    SolApathy ... Moderator Site Supporter Level 5

    Joined:
    Oct 10, 2015
    Messages:
    680
    Media:
    32
    Albums:
    1
    Likes Received:
    197
    Gender:
    Male
    Location:
    USA
    Vehicle:
    Charger SRT 392
    Vehicle Year:
    7th Gen - 2015
    Trim?:
    SRT8
    Color?:
    B5 Blue
    Check the battery level.
     
  7. Dodgeredline

    Dodgeredline New Member

    Joined:
    Dec 17, 2017
    Messages:
    10
    Likes Received:
    0
    Gender:
    Male
    Location:
    Tulsa Oklahoma
    Vehicle:
    charger
    Vehicle Year:
    7th Gen - 2011
    Trim?:
    Mopar11
    The dealer is going to pick it up ill post up the diagnostic when ready.
     
  8. Dodgeredline

    Dodgeredline New Member

    Joined:
    Dec 17, 2017
    Messages:
    10
    Likes Received:
    0
    Gender:
    Male
    Location:
    Tulsa Oklahoma
    Vehicle:
    charger
    Vehicle Year:
    7th Gen - 2011
    Trim?:
    Mopar11
    Well they finally fixed it lol. They said it was the rack an pinion but now im left with a load wistle sound.
     
  9. SolApathy

    SolApathy ... Moderator Site Supporter Level 5

    Joined:
    Oct 10, 2015
    Messages:
    680
    Media:
    32
    Albums:
    1
    Likes Received:
    197
    Gender:
    Male
    Location:
    USA
    Vehicle:
    Charger SRT 392
    Vehicle Year:
    7th Gen - 2015
    Trim?:
    SRT8
    Color?:
    B5 Blue
    Rack and pinion? Err, rack and pinion issues aren't going to cause it not to start.
     
  10. Dodgeredline

    Dodgeredline New Member

    Joined:
    Dec 17, 2017
    Messages:
    10
    Likes Received:
    0
    Gender:
    Male
    Location:
    Tulsa Oklahoma
    Vehicle:
    charger
    Vehicle Year:
    7th Gen - 2011
    Trim?:
    Mopar11
    Thats what im saying its a bit fishy, an a load wistle annoying as hell.
     
  11. Dodgeredline

    Dodgeredline New Member

    Joined:
    Dec 17, 2017
    Messages:
    10
    Likes Received:
    0
    Gender:
    Male
    Location:
    Tulsa Oklahoma
    Vehicle:
    charger
    Vehicle Year:
    7th Gen - 2011
    Trim?:
    Mopar11
    Loud*
     
  12. djalbin

    djalbin Active Member

    Joined:
    Feb 21, 2014
    Messages:
    1,508
    Media:
    7
    Albums:
    1
    Likes Received:
    186
    Gender:
    Male
    Location:
    Tucson, AZ
    Vehicle:
    Charger R&T STP
    Vehicle Year:
    7th Gen - 2012
    Trim?:
    R/T
    Color?:
    Pitch Black
    I have heard of the car not starting due the EHPS (electrohydraulic power steering) unit going bad but the rack & pinion steering unit is a new one on me. Loud whistle noise can be caused by several things:
    Mis-routed power steering hose.
    Restriction in pressure or return hose.
    Noisy valve in power steering gear.

    When they installed the new steering unit, they should always use a new O-ring on the ends of the steering hoses and lubricate the new O-ring with clean power steering fluid. They also have to fill and bleed the power steering system.

    I would have the dealership check the installation for hose routing and which hose is causing the noise. They have electronic listening tools that can determine where the noise is coming from. They can also check for a noisy valve in the steering gear as well as the fluid level in the EHPS reservoir (hopefully they purged all the air from the power steering system when they filled it with fluid).
    .
     

Share This Page