Dodge Charger Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hey guys, I have a 2009 dodge charger 3.5L and the A/c has been giving me so many issues. Neither the compressor or fan isn't working. Now I have the right amount of refrigerant in the system and still nothing. I believe I have a electrical issue maybe somewhere in the system, my next step is changing the transducer because I am thinking maybe its commanding the PCM not to turn on anything on because its no good. Any ideas?
 

·
Registered
Joined
·
2,929 Posts
I assume you checked all the HVAC fuses & relays?
AC clutch fuse
AC clutch relay
HVAC blower relay
.
 

·
Registered
Joined
·
2,368 Posts
Bad pressure sensor switch maybe? I've seen that happen on a nissan. We replaced the pressure sensor, refilled and all was good.
 

·
Registered
Joined
·
11 Posts
If the blower motor fan isn't coming on the compressor won't come on. This was true in my Avenger and my wife's Cherokee. I had to replace the control panel in the Avenger and the blower motor in the wife's car.

Does the blower motor come on when you turn on the heat?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
If the blower motor fan isn't coming on the compressor won't come on. This was true in my Avenger and my wife's Cherokee. I had to replace the control panel in the Avenger and the blower motor in the wife's car.

Does the blower motor come on when you turn on the heat?
Yes it does, everything functions properly but when I command the Ac to operate, my compressor clutch nor my rad fan don’t turn on.. my compressor isn’t seized either.
 

·
Registered
Joined
·
11 Posts
On the compressor there's a small plug. Verify that the ground is good and that it is getting 12v when the switch is on. If the ground is bad it's an easy fix to ground it properly. If it is getting 12v it's a bad clutch and that gets a little more involved to replace.
 
1 - 9 of 9 Posts
Top