Dodge Charger Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello all.
I have tired everything to fix P2173 Flashing Red Lighting Bolt. I changed the EGR gasket as well as the EGR Valve. I have cleaned the throttle body and the Intake. Checked all the gaskets.
The car runs fine while driving, but sometimes cruising down the highway it will go into limp mode and flash the red lighting bolt. Pull over, restart the car and good to go. At a red light it will do it, sitting there idling normal, then it stalls or just about stalls, shake shudder then idle up to limp mode 1200rmps with the flashing red lighting bolt.
I googled the crap outta this with no luck fixing it. Anyone had the same symptoms or something like this?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Thank you for the link. My problem is intermittent which is leading me to the throttle body failing. I have an appointment with Dodge on Monday, hopefully they can see something.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Update: Dealership scanned the car, eveything was out to lunch, they did a relearn and the car cleared most of the fault codes on its own. After that they found the upper intake gasket was bad and bleeding air. I change the gasket....but still having the same intermittent flashing red light. I ordered a new throttle body, just arrived today. I hope it fixes the problem. Ill let yous know.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
Update Fixed! I finally got it. It was not the throttle body, or any sensors. It was the lower intake gaskets.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
No Oil leaks. No coolant leak.
There is major vaccume leak with bad lowers. Loss of power yes. What I notice is when letting off the throttle, there is verry little back pressure to slow down the car, which is bad because you could have a run-a-way. The computer was doing its job, going into limp mode and throwing P2173.
What I found is the seals for the water jackets are perfect, the seals for the air intakes were cooked.
 

Attachments

·
Registered
Joined
·
1 Posts
Hello all.
I have tired everything to fix P2173 Flashing Red Lighting Bolt. I changed the EGR gasket as well as the EGR Valve. I have cleaned the throttle body and the Intake. Checked all the gaskets.
The car runs fine while driving, but sometimes cruising down the highway it will go into limp mode and flash the red lighting bolt. Pull over, restart the car and good to go. At a red light it will do it, sitting there idling normal, then it stalls or just about stalls, shake shudder then idle up to limp mode 1200rmps with the flashing red lighting bolt.
I googled the crap outta this with no luck fixing it. Anyone had the same symptoms or something like this?
I tried cleaning the sensor and got rid of 2173 code
 
1 - 9 of 9 Posts
Top