Dodge Charger Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
suppose this could go under mechanical or electrical, but here goes;

My 2008 AWD R/T has been throwing the p2767 code for a while now. It started off, it would occasionally go into limp mode but be fine after restarting. This became more and more common so I ordered transmission conductor plate. While waiting for the part, the car started not shifting beyond 2nd (i think? maybe 3rd?), not going beyond 3000rpm or 30mph. Not sure if this is limp mode as well but much different from my experiences with limp prior to this problem-- back then it just felt like lack of power and not revving past 2k. It is also now slamming into gear (reverse and drive), and autostick doesn't work.

This morning I installed the new conductor plate, but the problem still exists. As does code p2767.

What would your next steps be in diagnosing the issue?

any advice is much appreciated. Thanks!
 

·
Registered
Joined
·
2,920 Posts
All the different symptoms you described for Limp Mode are just different modes (limitations) that can be applied in Limp Mode. P2767 is the Input Speed Sensors. This diagnostic code is set if the Input Speed Sensor signal is equal to 0 RPM when the engine speed greater than 450 RPM.
The Input Speed Sensors are mounted on the plastic Electrical Control Unit. The Electrical Control Unit is mounted on the metal Hydraulic Control Unit. The two control units make up the Electrohydraulic Control Unit.
.
 
1 - 2 of 2 Posts
Top