Dodge Charger Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
So I pick my car up on the 20 seconds I've got it for a total of about 23 maybe maybe 24 hours I stopped at the bank on my way home yesterday take care of my business inside I come outside to leave jump in the car and the car won't start. Checked battery connection they were good nothing out of place under the hood
Called dealer that send a flatbed.
So I then pull the transmission lock release so I can get it out of park and into neutral to push it out of my parking spots to make it simple for the tow truck driver to load the car. Only it does not release..
This sucks I have a brand new cold air intake waiting to go on it a lower air intake that's been ported and I have a brand new and a brand new Flowmaster Force II exhaust setup being shipped to my house right now. And I have an appointment set up for window tinting in several weeks.

Kind of depressing hopefully it's nothing serious or it's able to be corrected within the week
 

·
Registered
Joined
·
604 Posts
Did you pop off the button and try inserting the key? Basically by-passes the button. Plenty of videos out there showing this.
 

·
Registered
Joined
·
85 Posts
Did you pop off the button and try inserting the key? Basically by-passes the button. Plenty of videos out there showing this.
If you find the video please post a link. I could not find one for the charger just one for a challenger and they have an odd keyfob.
 

·
Registered
Joined
·
604 Posts
Never mind, I was thinking the earlier key fob. The pear shaped one. The newer one you place the fob against the button and try to start it.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #10
You know I'm not really sure what the hell happened man I turned the car off and as the engine stopped I heard this metal click sound come from the engine I didn't think much of it then. I went into the bank did what I had to do came out and jumped in the car and went to start the car and the engine would not even turn ove.
So I talked with the dealer on Monday and my service writer told me that it will take 22 hours to install that engine once they get it so maybe another week without my car. I don't understand why it would take that long. When I was in the Navy me and the guys in the engine room removed and swapped out a blown LM 2500 gas turbine engine for a brand new one that was sitting there waiting for us on the docks we rigged it up and we rigged it down in about 3 days.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #13
Dealership just called and then should be in either this Friday or next Friday hopefully it's this Friday because then they will be able to get started on it on Monday morning
 

·
Registered
Joined
·
28 Posts
Discussion Starter #14
The problem is getting the engine, not the install part. There's a shortage of them.
Yeah so you'll never guess what happened two weeks after I got the car back that brand new engine that they put in blew a rod out the block. Was told the second replacement would be in next week
 

·
Registered
Joined
·
85 Posts
Yeah so you'll never guess what happened two weeks after I got the car back that brand new engine that they put in blew a rod out the block. Was told the second replacement would be in next week

WTH... Really? I would be pissed. I have to ask you don't drive like an a$$ hat and you use pump gas? I for the most part drive it like I stole it.lol
 

·
Registered
Joined
·
946 Posts
Yeah so you'll never guess what happened two weeks after I got the car back that brand new engine that they put in blew a rod out the block. Was told the second replacement would be in next week
That is one of the most redonkulous things that I've heard in a while!!! I would be BEYOND livid and someone would be buying me out of my loan and getting me into a different car! I'm soooo sorry bro that you are having to deal with that asshattery...and what orig. started with the button and a possible engine issue....!!

I too also drive her like I stole her...practically every moment that I'm behind her wheel...lol!!! I am def a HOONIGAN!!!
 

·
Registered
Joined
·
28 Posts
Discussion Starter #18
No I don't dog my car. This happened at 4a.m. 2 blocks from my house doing 25-30

I put mid grade fuel in. Was in the break in period so hadn't done any heavy acceleration. All pretty normal driving. On the interstate 65-70 with Cruz control. Probably put only 800 miles on the engine.

I am upset but they are replacing engine at there cost. And given me cars off the lot to drive. I will say this the Kia Optima and the Hyundai Sorento are a lot nicer than I thought they were.
But this will definitely be the last time. If it happens again I will contact an attorney.
 
1 - 18 of 18 Posts
Top