Dodge Charger Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
Its a 2018 charger SP and today I got into my car and drove 100 feet when a "Service ESP" and immediately followed by "Service brake". I stopped the car and shut it off. I went to turn it back on and nothing. In order to start it I had to pull the ECM fuse. This car is 100 percent stock. Now my CEL is gone as well. Any ideas?
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #3 ·
Also, I wasn't able to read the codes before they cleared. I was also wondering if an over filled catch can would cause such issues. I went to drain mine and it was definitely neglected on my part. No issues since however id like to know if it could be something else. Ya know just in case.
 

·
Registered
Joined
·
948 Posts
So the car isn't 100% stock if you added a catch can is it. Pulling the fuse may have cleared the CEL.

Was the can full enough to block air flow? Like if the junk inside sloshed around? Carefully pinch the hose and see if you can recreate the problem
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #5 ·
I dont consider a Catch can to be a "Mod". Its basically a filter.

In any case yes if the junk inside spilled over could it cause that? I would think it would start spitting smoke like crazy if it did. I will try what you suggested today or tomorrow. Thanks.
 

·
Registered
Joined
·
948 Posts
Yeah catch can is not a mod like a camshaft. But it's a mod you did to your car that probably caused your cel
 
1 - 6 of 6 Posts
Top