Dodge Charger Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
09 Charger 5.7L, PP, 149k miles. I bought it about 5k miles(1yr) ago. About a week ago, I noticed an odd occasional shimmy, which I first attributed to poor paving on the freeway. But the other day, on the same freeway, the shimmy became more of a shudder, bad enough that I caught the next off ramp, flipped a *****, and came right back to park it. It's hard to say, for sure, but it seems like it was worse when cold,, and worse when under load,, like mild acceleration or going up an incline. No obvious "check engine light" or other warnings. I have not put a scanner on it, yet.The tires are relatively new, brakes are great, auto trans fluid level appears about right and the fluid looks bright pink, like it had been changed in the recent past. Has anyone experienced a similar problem?
 

·
Registered
Joined
·
1,450 Posts
I guess I would look at the differential oil level. See if the outside is wet but who knows, someone could have changed it and not put enough in? I would look there. I had another type vehicle do this and found the differential was low and was doing the same thing. She blued the bearings she was so low and hot and was trying to seize.
 

·
Registered
Joined
·
1,450 Posts
The earlier year models had a bad oring on the trans fill tube. The NAG1s do not tolerate water in the fluid. Could be you have some.
 

·
Registered
Joined
·
1,450 Posts
All I know is it does not take much to cause trouble.
 
1 - 6 of 6 Posts
Top