Dodge Charger Forum banner
1 - 20 of 45 Posts

·
Registered
Joined
·
245 Posts
Discussion Starter · #1 ·
Hey guys anyone else notice a high pitch whistling noise coming from the engine bay when accelerating lightly with the windows down? It gets louder and softer with the RPM but if you accelerate hard it goes away. It's only when you push the pedal lightly. I hear it a lot because I drive in the city a lot. It bothers me cause I feel like something is wrong. I searched on here but couldnt come up with a definite answer. Any help is appreciated. :4-dontknow:
 

·
Registered
Joined
·
180 Posts
i have this same problem... i was going to bring it up to the service department this week when i bring my car in for its routine maintenance... so when i find out what they say i will let you know... if i dont get back to you by saturday then pm me because i probably forgot lol...
 

·
Registered
Joined
·
1 Posts
same problem

I just bought an 08 3.5l and have that same problem, I took it too the dealer ship and they said it was the fuel pumps. so they replaced both fuel pumps and still makes that noise. when I brought it back i made one of the mechanics ride with me to hear the noise and he could not give me a definite answer, except to tell me that there are a lot of things it could be. I am taking it to a different dealer ship on Monday, I will keep you posted if i find out what is wrong. Please let me know if you find the answer before I do.... that noise is so annoying
 

·
Registered
Joined
·
245 Posts
Discussion Starter · #7 ·
I just bought an 08 3.5l and have that same problem, I took it too the dealer ship and they said it was the fuel pumps. so they replaced both fuel pumps and still makes that noise. when I brought it back i made one of the mechanics ride with me to hear the noise and he could not give me a definite answer, except to tell me that there are a lot of things it could be. I am taking it to a different dealer ship on Monday, I will keep you posted if i find out what is wrong. Please let me know if you find the answer before I do.... that noise is so annoying
Yeah I never got it solved... Just learned to ignore it. I've got a CAI now which whistles slightly too so it's not a big deal anymore. But let me know if you ever get it figured out.
 

·
Registered
Joined
·
2,052 Posts
thats weird, ive never run into this problem...until just recently :LOL:
 

·
Registered
Joined
·
140 Posts
blstrick55, have you figured out the problem yet? I have the same issue, it could be so many things. If anyone else has figured it out please post, I think this is a common proble. I might try cleaning my TB one of these days.
 

·
Registered
Joined
·
245 Posts
Discussion Starter · #11 ·
blstrick55, have you figured out the problem yet? I have the same issue, it could be so many things. If anyone else has figured it out please post, I think this is a common proble. I might try cleaning my TB one of these days.
Nope, I'm not really looking into it anymore. I've got the CAI since I started this thread and it whistles slightly too so it's not big deal anymore. But if you figure it out let me know!
 

·
Registered
Joined
·
140 Posts
Ya for real, I'm sending mad reps to the person that finally does figure it out. Seems to be a fairly common problem yet no one knows what it is!

Anyone think it could be a vacuum leak?
 

·
Registered
Joined
·
3,661 Posts
It could be the alternator making the whistling noise. I have also heard that the windshield will make a whistling noise on some LX cars because there is a tiny gap in the seal on the windshield from the factory and the air going through it will whistle. My car does it but only between around 20-40mph. Its very faint but I can hear it.
 

·
Registered
Joined
·
140 Posts
mine's related to when you touch the accelerator for sure. it actually goes away if you press it hard enough. that or if you're at a constant speed it's there. really hard to figure out. thanks for the advice though! what has to be done to see if there's a vacuum leak?
 

·
Registered
Joined
·
3,661 Posts
mine's related to when you touch the accelerator for sure. it actually goes away if you press it hard enough. that or if you're at a constant speed it's there. really hard to figure out. thanks for the advice though! what has to be done to see if there's a vacuum leak?
When I had my K&N CAI, it would also make a whistling noise while at partial throttle. I could hold the pedal in the same position and it would whistle the whole time but as soon as I let up or pushed the pedal in more, the whistle would stop. So it could be possible it is your CAI if you have one. If it is then its normal for a CAI to whistle.
 
1 - 20 of 45 Posts
Top