Dodge Charger Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Has anyone had this issue my 2013 starting having a issue a day ago....when I started it the menus screen went white for a second and the car had a hard time starting up the next day white screen again but it wouldn’t start at all, had a friend give me a jump and it started so I figured it was probably the battery (which I haven’t changed since I bought it almost 2 years ago) took it advanced auto they tested the battery and said it was fine even had more charge then needed but said the reading was saying something was wrong with the starter...now I had the starter replaced about a two years ago by the dealer so I found that strange anyway I had it towed the tow truck guy said let me hook it up to his jump box just to see and the car started right up but still has the white screen then goes back to norm menu display......any idea of what this is??
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Wheeeeeeeew, that's a long sentence. So the problem is the white screen at times?
Thanks for replying sorry for long sentence, but no I guess the white screen is just a indication of what’s wrong. The main thing is it won’t start without a jump most of the time and when it does start without one I get the white screen and it barely turns over.
 

·
Registered
Joined
·
7 Posts
Had a similar issue today. Started on the second try and car info screen took a bit longer to come on. Started when I took the key fob in my hand (bringing it closer to start button). Could key fob battery running low also cause that? Ran a OBD scan btw. Showed no codes
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
Yes it could be the key fob battery in your case ,that was one of the possibilities I looked into when I had my issue. I I learned about putting the key fob close to the start button on YouTube didn’t work for my though.
 

·
Registered
Joined
·
7 Posts
Yes it could be the key fob battery in your case ,that was one of the possibilities I looked into when I had my issue. I I learned about putting the key fob close to the start button on YouTube didn’t work for my though.
Thanks. I guess that's the cheapest solution to try out first.
 
1 - 8 of 8 Posts
Top