Dodge Charger Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Hi All - 2014 SXT-Plus - This morning the Yellow check engine light went on - yellow - solid - no blinking. Normally, I would think this is just an emissions check thing, and blow it off until tune up time, but the oil pressure readout in the Engine Info view is pegged at 99 psi at cold idle. Ambient temp is unusually hot for the NE. --98 degrees F with very high humidity.

Is the ambient temp blowing the O2 sensor's mind?

Anybody seen that with the oil pressure readout?

Vehicle seems okay, otherwise. No oil light. Oil has been changed religiously with full syn every 2500 to 3000 miles.

Anybody have insights to share?
 

·
Registered
Joined
·
2,327 Posts
If the oil pressure sensor went bad the voltage signal to the PCM will be outside the normal range and cause the PCM to log a DTC (diagnostic trouble code) and turn On the check engine light.
Plug a OBD2/CAN scanner into the car's OBD2 port (under the dash by the parking brake pedal) and see what DTCs have been logged. You can get a free scan at many of the auto parts stores if you don't have a scanner.
.
 

·
Registered
Joined
·
179 Posts
My '13 van with a pentastar threw P0520 & P06DE codes at only 7k miles. The oil pressure readout stayed pegged at 99 and never changed.
The oil pressure sensor was replaced (under warranty), so that may be the issue.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
Thanks! Yes -- Oil pressure sending unit (a.k.a. sensor) was the issue, as you guys mentioned, and it showed up on the scanner. I was just out of the warranty period. I changed out the oil cooler as well, which was leaking.
 
1 - 4 of 4 Posts
Top